Tuesday, May 27, 2008

Msn key ports error solution


When you encounter msn key ports error as above, follow the steps below:

1. Go to Start --> Run


2. Type cmd

3. Type netsh winsock reset catalog then press enter (to reset winsock entries to installation defaults)

4. Type netsh int ip reset reset.log then press enter (to reset tcp/ip stack to installation defaults)




32 comments:

Joe Mac said...

I have entered the command suggested - the message returned is "the requested operation requires elevation"
Still cannot access Windows Live - any ideas !!!

Eyal said...

Try running CMD with the Administrator rights. (right click on the CMD and choose "Run as Administrador")

Dino said...

This works on me.

Anonymous said...

Once run as administrator worked for me too.
Thanks so much

Anonymous said...

Entered both commands and restarted - Live Messenger is now working fine without the ports error. Thank you I'd been trying to solve this for ages! Extremely helpful advice.

Anonymous said...

i first clicked on "run as administrator" and then entered the suggested commands and i still got a returned text saying "the requested operation requires elevation" therefor windows live still isn't working! :( do you have anymore ideas? thank-you in advance :)

Anonymous said...

when i get to the netsh int ip reset reset.log it says"the following command was not found" can you help me??

Anonymous said...

This solution was made for XP, no other windows operating systems (as far as i know) also some of the files might be missing

Anonymous said...

Works great, Thanks! This issue continues to happen when I switch ISP's. Thanks for the help.

Anonymous said...

Um, doesn't work for vista, does ANYONE know any solution to do it for vista :/

Anonymous said...

Great!! It works for me. I almost re-install my XP.

Anonymous said...

Confirmed. It worked magic for me. :)

Anonymous said...

thanks...it work for me... :)

Anonymous said...

I am running vista and this worked for me. Thanks alot.

Anonymous said...

its notworking for me and ive tried finding run as administrator and its not working.

can someone email me thanks

carter_1990@hotmail.co.uk

Anonymous said...

i done that but its still saying the key ports are broke

anyone help me

msg me on
ninjwan@yahoo.co.uk or .com

Monster-Maniac said...

Worked for me. Thank you!

Anonymous said...

Worked awesome! Thanks!

Anonymous said...

works for me on windows 7

errgubaa said...

just check the calendar of your computer.

and set to the real date.





my friend just told me!!!




my msn cannot access two week ago,
but I can fix it in two minute .....


oh... dearr

mhmud said...

key ports error

i found that i use netlimiter program
and i shut it off
and the error resolved

thnk to all

Anonymous said...

That worked for me ... thanks :)

bekim said...

Thanks sir very much its work for me you are genius

George said...

Thanks for this! By the way do you know what could be causing this issue? I am having this problem constantly and I have to reset the tcp/ip and restart system...

mido said...

thaaaaaanx it worked perfectly

Anonymous said...

It did not work for me I am an admin,I did all the steps and ran some registry cleaners to see if might be registry problem, but it wasn't, I don't no what to do now.
:(

Anonymous said...

worked perfectly! thanks!

Anonymous said...

works fine on windows 7 thanks very much

Anonymous said...

thanks worked after loggin in as an admin

Anonymous said...

worked for me only logged in safe mode and not as a user.

Anonymous said...

I had this same problem, none of these solutions fixed it for me. What finally did fix the problem was getting rid of my hughes satillite internet and switching to a land based dsl through my phone company. Not one disconnect since I changed over. The disconnect/reconnect was constant with my satillite connection.

xerxesgunes said...

It's worked on my but only the command netsh winsock reset catalog

I got this msg: Sucessfully reset the Winsock Catalog.
You must restart the machine in order to complete the reset.

Bu without restart it worked!